


Introduction To Arcview

This introduces you to ArcView version 2.0, shows you how to start it, and directs you to on-line sources of information.
What is ArcView ?

ArcView is a powerful and easy-to-use tool that brings geographic information to your desktop. AncView creates an environment
to display and query the contents of a spatial database. It allows you to explore the database. display all part of ils contents, ask
questions, display or save results, and pass information or graphics on o other applications.

What Can You Do with ArcView ?
Here are some of the key tasks you can accomplish with ArcView,

Display ARC/INFO Data

Display tabular data on a view

Import tabular data and then join it to the data in a view o display it geographically
Find the attributes of any features

Classify features with different symbols according to thetr attributes
Select features according to their attributes

Find places where certain features comncide

Summarise and generate statistics on the attributes of features
Create charts showing the attributes of features

Lay out a map and print it

Lay out a map and éxport it for use in another applxcation
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Chapter 1

Projects and Views: Managing Your Work and Displaying and Querying Spatial Data

What is a Project 7

All the components of your ArcView session - views, tables, charts, layouts, and scripts - are conveniently stored in one file called
a project. The project file shows you the contents of your project and makes it casy to manage all your work. Project files have the
AFR extension.

When you open a project file, the components in the project are listed in the Project window. From the Project window, you can
add or remove components from your project and give a component a descriptive name,

What is a View 7

A view is an interactive map that lets you display, explore, query, and analyse geographic data in ArcView, A view defines the
geographic dats you use and how to display it, but it does not contain the geographic data files themselves.

S




A view is actually a collection of themes, A theme represents a distinct set of geographic features in a particular geographic data
SOUTTE.

What is a theme 7

A theme is a set of geographic features in a view. A theme represents one of the following sources of geographic data:
* anspatial data source, such as an ARC/INFO coverage,

= animage data source, such as a satellite photo, and

* atabular data source containing events, such as a table with X, Y coordinates.
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The themes in a view are listed in its Table of Contents. For example. a view of a city might have one theme representing major
highways, metalled roads. non-metalled roads, and one theme representing the drainage network of an area, etc.

Each theme has its own legend displayed in the Table of Contents. A theme's legend controls how the theme s displayed on the
view. You can edit the colours and svmbols of a theme.

Table of Contents
On the left side of the view's window is the Table of Contents which lists the themes in the view and controls the visibility of the

themes and drawing order. Each theme, has a check box on the left side. To display the theme, click the check box. The check mark
« appears in the check box and the theme is displayed.




When you are working with a view, you will see the view's menus, buttons, and tools.

Working with Views in a Project

An ArcView project can contain any number of views.

To see which views are in a project, click the Views button in the project window. The views in the project are shown in the list.
To create a new view, with the Views button selected, click the New button at the top of the project window. A new empty
view will appear. ArcView names new views in numerical order: View1, View2, View3, and so on,

To open a view, double click the view's name in the list of views in the Project window, or select the view's name and click the
Open button.

To close a view, choose Close from the File menu,

To rename a view, click once on the view in the list in the Project window and choose Rename from the Project menu.

To delete a view: click once on the view in the list in the Project window and choose Delete from the Project menu. To select
several views for deletion, hold down SHIFT and click the other views to delete.

To save the work undertaken with a view, choose Save Project from the File menu or click the Save Project button in the View
button bar.

To copy a view from one project to another, if you want to get a view that is in another project and put it into your current
project, you should import the other project inte your current one using Import in the Project menu. This will copy all the
components of the other project into your project.

Intreduction to ArcView 2.0 A Lab Exercise 159



Training Manual for Policy-Makers 160

Exercise 1

There should be an existing database for ArcView to work. For this lab exercise, you will use the Bagmati datasets on a scale of
1:250,000. The available ARC/INFO datasets of Bagmati Zone that you can practise with and incorporate into your projects are:
Outline, District Boundary, Elevation, Ecological Regions, Roads, River, National Parks and Protected Areas, Settlements, and Spot
Heights.

In this exercise, you will learn the following.

* How to create a project

* How to create themes

* How to edit a theme's legend

* How to classify spatial data

* How to move around the display

* How to carry out spatial analysis

* How to select features

* How to carry out logical selection
* How to define themes

* How to edit a theme

Getting Started

Click the ArcView icon [B to start ArcView from the Microsoft Office Window.

Creating a Project

When you create a project, you create one file that contains the views, tables, charts, layouts, and scripts that make up the project.
To create a project, choose New Project from the File menu.

ArcView creates a new project called Untitled and opens the Project window.



Creating a Theme

You can create a theme, selecting the data source that you want it to represent. Any supported data that you have read access to
can be created in a view as a theme.

To create a theme of ARC/INFO coverages of the Bagmati dataset -

From the View menu choose Add Theme or click the Add Theme button to display the Add Theme dialog box.
In the Data Source Types box, choose Feature Data Source if it is not already selected,
Mavigate to the directory d:\gistm\ data\ bagmati where the ARC/INFO coverages of the Bagmati dataset are contained.

Jd\gistrn\data\bagmat

@ Direclories
) Libraries

Datn Sowrce Types: Drives:
| Feature Data Source [l] [d

Now double-click all the features one-by-one and press OK. ArcView will add the coverage to the view's Table of Contents
and choose the feature class for you.

To add all the ARC/INFO coverages into & view at once, select the coverages by holding down SHIFT and clicking on the
coverage, and then press OK.

When you create a theme, ArcView does nol immediately draw it on the view. This enables you to first edit the theme's legend or
change the drawing order. To draw the added theme, click on the check box next to the theme's name in the view’'s Table of
Contents.
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Now, to draw the roads of Bagmati, click on the Roads’ theme. The roads will be displayed in a view. You will notice that all the
roads are displayed in one colour, which indicates they are the same type of road. However, they are not. Five different types of
road are defined in this coverage. So, to display five different types of road in a view, you need to edit the legend of the theme
Roads.

Editing a Theme's Legend

By editing a theme's legend with the Legend Editor you can change the patterns and colours of the symbaols that ArcView uses to
draw the theme in your view.

To edit the legend of Roads, first click once on the theme Roads in the Table of Contents to make it active. Then choose Edit
Legend from the Theme menu or double-click the theme Roads. ArcView will display the Legend Editor.

e —— |



Theme: | Road Network ]
Field: [ Roads_id | Esave |
Symbols O Lebels & Valuss

N/

WAVEE:
| AN

VY,

In the Theme box, you will notice that Roads is selected, which is correct, and, in the Field box, None is selecied, which you have o
change. Click the 7 button in the right comer of the Field box. The items of the Roads’ coverage will be listed. Select the item

ROADS_ID according to which roads are categorised. Then you will see that the [D values and the cormesponding symbols are
displayed. Edit the ID values accordingly to 1,2.3,5.6.
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MNow, change the colour of the lines using the colour palette. To display the roads with the [D value 1 in red, double-click on a
symbol in the Legend Editor, The pen palette (figure) is displayed in which you can define the thickness of the line. To change the
colour, click once on the colour button. The colour palette is displayed, choose red. As soon as yvou choose red, you will notice that
the colour of the line in the symbol field of the Legend Editor has changed to red.




— | Color Polette |

El-l:'-. I:]
Cap: | Butt | |
Join. [Miter N

Similary, change the colour of the other individual lines as you desire.

After choosing the colours, the next step Is adding labels, You can enter your own text label next to each symbaol in the theme's
legend in the Table of Contents. This allows you to describe what each symbol represents. Press the Labels’ button on the Legend
Editor and enter the text you want to appear next to each symbol. Add the text lor each type ol road as follows.

Metalled Eoads
Non-metalled Roads

2

3

4 Pack Track
3 Local Tralls
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Thems: | Rond Metwork |i

Field: | Roads_id ]

Metalled Roads
Unmataliad Roads

Pack Track
Local Trails

AF=
ESavE
|EDEEED)
EEnEp
[EBandom)
|

Press Apply and your labels and colours will appear in the Table of Contents. Click the check box to display your results in a view.

Hiding a Theme's Legend

The legend of each theme in a view is normally shown in the view's Table of Contents. However, You can save space in the Table
of Contents by hiding legends. To hide a theme's legend, click on the legend to make the theme active, and then choose
Hide/Show Legend from the Theme menu,

Classifying Spatial Data

By specifying a range of symbols, you can symbolise and classify the features in a theme based on the values they have for any
field in the theme’s attribute table. You can change the classification and symbols of a theme with the Legend Editor.

To classify the features, the procedure is as follows.




* In the Legend Editor, choose the name of the field you wish to use to symbolise the theme,
= 5S¢t the number of classes or type of classification you require by pressing the Classify button to set the classification to either
Cuantile, Equal Interval, or Unique Value,

Clnssihcolion

® Quantile S —
» Equal Interval
» Unigue Value

Mumber of Classmg 5 |

To choose a random range of colours, the procedure is as follows.

= Press the Random button in the Legend Editor.

Up to now, you have created a theme for the Roads’ coverage. Similarly, create themes and edit the legends of other coverages.
Move Around the Display

* You can use the view button bar and tocl bar to move around and zoom in on the display,

* Use this E button to zoom to the full extent of all the themes in a view which allows you to see everything.

*  Click on a theme in a view's Table of Contents to make it active, and then click this button - to zoom to the area covered by
the active theme.

, ;
+  When you have selected the features on a view, click this button to zoom to these features of the active themes of the view,
*  Use this button In to zoom in on the centre of a view,
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Use this button I 1 to pan the view by dragging it in any direction at any time.

Performing Spatial Analysis

Spatial analysis operations provide the means to look for or determine relationships between themes, to assign the attribules of
another, and to perform aggregation of both features and attributes.

Spatial analysis operations available in ArcView include the following.

& & @& & & & @

Finding point features that are nearest 1o the selected point or line features

Finding pownt features according to the polygon features they fall inside (point-in-polygon)

Finding line features according to the polygon features they cross (intersection).

Finding polygon features according to the polygon features with which they coincide (intersection; polygon-in-polygon)
Finding features that are adjacent to the selected features

Creating new features by merging a set of adjacent features into one single feature or aggregate disjunct features
Selecting features by specifying a buffer distance

Selects the features of the active themes with the features of the theme you specify, Choose Select By Theme in the Theme menu.

To select a theme using another theme, follow this procedure.

1
F
3

4

ARy

. Make the themes to be selected active. Those are the target themes.,

In the Theme menu, choose Select by Theme.

. Choose the spatial relation type.

This phrase qualifies the selechion. ArcView provides several spatial relation types. The types you see depend on the selector
theme's feature type. In some cases, you may want to pick the selector theme before choosing the spatial relation type.

Pick the theme from which the features are used o make the selection.




This is the selector theme. ArcView selects features in the target themes using the selected features of the selector theme. If no
features in the selector theme are selected, ArcView uses all the selector theme's features to select.

5. If you choose Are Within Distance of, specify the selection distance.
ArcView selects the features in the target themes whose distance to any of the features in the selector theme is less than or
equal to the selection distance. The selection distance units are the distance units of the view, Set the distance units in the View
Properties dialog box.

6. Choose a selection method.
ArcView provides three selection methods. New Set creates a new set of selected features from all candidate features. Add to

Set adds new features to the existing selected set of features. Select from Set selects features only from candidates in the
currently selected set of features.

Notes

* Specifying a selection distance essentially creates a buffer polygon around the features of the selector theme; however, the
buffer polygon is not visible.

* If you specify a selection distance of 0, ArcView selects the features that intersect the selector theme's features. A selection
distance of 0 selects all points in the target themes that fall within a polygon, all lines that intersect, and all lines that intersect
the selector theme's polygons and all polygons that intersect the selector theme's lines.

*  ArcView uses the selected features of a theme to make the selection; therefore, if the active theme is the same theme as the
selector theme, and you choose Intersect, you can select features that are adjacent to the selected features.
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Example

To identify the Settlements that are within 1,000 Metres of the Roads

1. In this example, you are dealing with the distance. So, your first task is to set the map and distance units. To do this, choose
Properties from the View menu. Set the map units and distance units to metres and press OK

2 Activate the Settlernent in the view’s Table of Contents by clicking once, if it is not already activated.
3. Click the check box to display the settlements and roads.

4. Select Select by Theme from the Theme menu.

5. In the Select features of active themes box, select Are within Distance of.

6. In the Selected features of box, select Roads.

7. Select New set 1o exit from the Select by Theme menu and wait for a few seconds. ArcView will display the settlements within
1,000 metres of the roads in different colours {yellow).

You can check your results by measuring the distance of marked and unmarked settlement points from roads, Te do this,
1 elick the measurement B8l button,

2 select any yellow marked settlement point by clicking once, and

3. stretch the measurement cursor to the roads around it.

The distances will be displayed on the lower left hand cormer of the screen. Similarly, check for other points,




Selecting Features
Selecting leatures on a view enables you o

* find specilic geographic features that interest you or meet certain important criteria, and

*  work with specific geographic features in a variety of ways to find out more about them.

There are several ways to select festures on 8 view. You can select them according to thelr location, according to their attribute
values, or by selecting their records from a table. You can select features from one or more theme=. Before you can select features
from a theme. vou have to click on the theme in the Table of Contents to make it active.

Features highlights views when they are selected and they remain highlighted until a different selection is made, or until they are
deselected.

Selecting Features with the Mouse

The Select Feature tool allows you o select features with the mouse by pointing at them or by dragging a selection box over them
Features that fall partly or wholly inside the box you define will be selected.

2electing Features Using Shapes

Shapes, such as circles, boxes, ines, and polygons, drawn on a view using the Draw 100l can be used to select features. Simply
draw the shape and then press the Select Features Using Shape button.

Selecting a Feature Using Find

Find is a quick way to select a particular feature of interest. For example, if you are working with a theme of the settlements and
you want to select Koteswor, simply type the name into the Find dialog box,

Selecting Features Using a Query

Use a query when you want to select features according to their attribute values. For example, you can build a query to select all
the settlements in Bagmagi Zone with populations of mare than 10,000, You can also build more complex gueries.
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You can also use the Query Builder to narrow down your selection by building a query that only selects features from the set you
have already selected.

Example You Have a Theme Displaying the Point Locations of Seftlements, and Want to Find Out the Settlements within a 10,000 Metre
Radius of Kathmandu Municipality

In this case, you do the following.

1. Click on the settlement theme in the Table of Contents to make it active.

2. Use the Draw tovol to draw a circle with a 10,000 metre radius centered on the Kathmandu Municipality location.

3. Choose the Select Features using the Shape button to select the settlements in this area.

4 Chick the Query Builder button. ArcView displays the Query Builder. Build a query to select the settlements having a
population greater than 10.000.

5. Press the Select From Set button on the Query Builder, From the set of settlements that i< already selected. ArcView will select
those that match the query.

Selecting Features by Selecting Records in a Table

A theme's attribute table contains one record for each feature in the theme. When you open a theme's attribute table containing the
attributes of a theme's features, selecting records in the table automatically selects the features they represent on the view.

To select leatures by clicking on records in the theme's attribute table

1. Click on the theme in the Table of Contents to make it active, if it is not already.

2. From the Theme menu choose Table or click the Open Theme Table button. ArcView displays the theme's attribute table.

3. Hold down SHIFT and click on the records you want to select. The features in the theme represented by these records are also
selected in the view (You can also use the keyboard to select records in the theme's attribute table.)

Selecting Features Using 2 Chart

A chart created from a theme's attribute table containg one data marker for each selected feature in the view. By erasing dala
markers in the chart, you can deselect features on the view. In this way, you can use the chart to focus on particular features of
interest.

pa—“. _#



Logical Selection: The Query Builder

The Query Builder allows you to select features on a view and records in a table by defining a query based on their attribute

values.

Butlding a Query

To build a query, choose a Field, then an Operator, and then a Value, You build a query by double-clicking on these options with
the mouse or by typing your query directly into the query text box. By default, the query is contained within parentheses.
However, parentheses may not be required, depending on the complexity of your query. If the Update Values choice is on, click
once on a field name to list its values in the Values® list. Field names are always enclosed in square brackets ([ ]). If the value you
want to use in the query is not in the Values' list, type it into the query text box.

Example

1. Toselect elevation zones between the range of 1500 - 2,500 metres, you can use the query (Note: Ttem GRID_CODE represents
the elevation value).
{IGRID_CODE] >= 1500} and ([GRID_CODE] <= 2500)

To do this:

C.

d.

.  click the theme RELIEF to activate it,
b.

select the Query Builder button (fig) OR select Query from the Theme menu,

to build the query, choose the field (GRID_CODE), then an operator (>=), then a value (1500), again an operator (and), then
the field (GRID_CODE), then an operator (<=), then a value (2500}, and

select New Set.

ApcView will display the zones that match the criteria.

2. Strings, such as names, are always quoted in queries. Strings are case insensitive, so you can select the VDC Bidur with:
{ VDCNAME] = "BIDUR" )

3. Use* as a multiple character wildcard. For example, to select Ramche you could use the query:
( [VDCNAME] = "RAM*™ )
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4. Use 7 ina string as a single character wildeard. For example, to find Salyankot and Methinkot, use
{ [VDCNAME] ="177777kot” )

5. To select all the VDCs with names starting with the letters D, you could use:
( [VDCNAME] > "I )

Defining a Feature Selection for a Theme

By default a theme represents all the features of a particular feature class i its data source. However, it is useful to be able to
restrict a theme to represent only a subset of the features in a particular festure class.

For example, you might have a data source that contains arcs for all the roads in your study area, but you want to create a theme
that only represents the major highways. In this case, you would first add the theme to your view and then edit its theme

properties to define a feature selection consisting of the major highways.

By defining a feature selection you can control exactly which features from a theme's data source are represented in the theme.
Features are selected based on the attribute values tn the theme's attribute table, The feature selection is defined as a query in the

Query Builder accessed from the Themw Propertivs dialog boox,
To define a feature selection for a theme:

click on the theme in the Table of Contents to make it active,

from the Theme menu, choose Properties or click the Theme Properties button - the Theme Properties dizlog boe will be
choose the Definiton category of properties U this has not already been chosen,

press the Query Builder button. ArcView displays the Query Builder,

build a query,

press OK on the Query Builder - your query appears in the Theme Properties definition box, and

press OK on the Theme Properties dialog box.

Arc View will select the features that match the query and redraw the view. Only those features that are selected in the query are
now in the theme.

A 2 e




Example

The theme NAT_FARK actually represents National Parks. The fitle itself may not be clear to all. Define the theme NAT_PARK as
Mational Parks to make it more clear.

1. Click the theme NAT_PARK to activate it, if not already activated.
2. Select Properties from the Theme menu,
3. Type National Parks in the Theme Name box and press OK.
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Chapter 2

TABLES: Attributes of Spatial Data

What is a Table ?

A table lets you work with data from various tabular data sources in ArcView, In fact, with ArcView's tables you can access almost
any tabular data resource in your organisation and work with it spatially!

* You can display, query, and analyse data in tables. You can highlight records in tables by selecting geographic leatures
displayed on views, and vice versa.

* You can display tables on a view to reveal the geography of your data,

*  You can easily create charts from tables to visualise trends, patterns, and distributions.
Warking with Tables in ArcView

An ArcView project can contain any number of tables.

To See wiich Tables Are tn o Project

Click on the Tables” icon in the Project window. The tables in the project are shown in the list

To Open a Table

Double-click the table’s name in the list of tables in the Project window, or select the table's name and click the Open button,

To Open & Theme's Attriluile Tabile

1. Open the view containing the theme.
2 Click on the theme o make it active.
3. Choose Table from the Theme menu or click the Open Theme Table button in the View button bar,

E——




When you open a theme's attribute table, it will appear in the list of tables in the Project window, [t can also be opened using the
Open button on the Project window, as described above.

To Add » Table inte a Project
Use Add Table in the Project menu to open a dBASE, INFO, or delimited text file as a table in your project.

You can add an INFO, dBASE 11, dBASE IV file, or a tab-delimited or comma-delimited text file to create an ArcView table in the
current project.

Adding Tabular Data

To add an INFO, dBASE, or text file:

1. open a project or make the Project window active for the open project.

2 from the Project menu, choose Add Table,

3. in the List Files of Type box, choose INFO, dBASE, or Delimted Text,

4 navigate to the directory that contains the file you want to add, and

5.  doubleclick the file you want 1o add or choose the file and press OK.

ArcView creates a table named after the file you selected.

Creating a New Table

You may want to create a new table in ArcView and then add data o it

Creafe @ New Table in Your Project

On the Project window, select the Tables' icon and then press the New button, Enter a name and a disk location for the dBASE file
that ArcView will create {o store the source data for the table. A new table will appear in your project. ArcView names new tables
in numerical order: Tablel, Table2, Table3, etc.

Add Fields to the Table

On the Table menu bar, select the Add Field choice from the Edit menu. The Field Definition dialog box will appear allowing you
to define the field in the table.
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Add Reconds to the Table

On the Table menu bar, select the Add Record choice from the Edit menu. This will add a single record to the table. Repeat this
action as many fimes as needed.

Add Data to the Table

On the Table tool bar, select the Edit tool. This allows you 1o edit the empty cells in the table.
Adding and Deleting Records

To Add a Record

In the Edit menu, choose Add Record.
If you add a record, use the Edit tool to update the values for the new record.

To Delete a Record

In the Edit menu, choose Delete Record. You must select one record before this choice becomes active.

Editing Records in a Table

By default, you are not allowed to edit a table. ArcView shows this by displaying the field names in the table in italics.

Omly tables based on dBASE or INFO files on disk may be edited. Tables that have been created by connecting them 10 o database
mﬁiﬁmﬁm\fhw does not commit changes back to database servers. You cannot edit tables created from

If you have the write permission to the data file on which the active table is based, and you wish to edit it, you can choose Start
Editing,

1f you do not have the write permission to the data file, Start Editing will be unavailable.

All editing, except for deleting fields and records, are immediately written to the source data file. To finish editing (and/or commit

— P \ :



Calculating Field Values

You can use the Calculate dialog box to calculate the value of the active number, string, date, or boolean field.

The value is the result of an expression that you enter into the text input area of the dialog box. The calculation applies to the
selected set of records. If no records are selected, the calculation applies to all records. You can enter the expression by double-
clicking on field names and requests or you can type the expression yourself,

In its simplest form, an expression can just be a number, a string, a date, or a boolean value. For example, to set the value of a
string field named [Zoning] to the string "Industrial”, type the string enclosed in double quotes in the text mput area of the dialog
box. To set the value of a number field to the number 143, type the number in the text input area of the dialog box.

In addition, an expression may consist of any combination of field names, enclosed in square brackets, and valid Avenue requests
that can be made on the class type of the field. The result of the expression must be a single object or value.

Sorting Records

Sorts a table on the active field. Click on a field name in a table to make it active and then choose Sort Ascending or Sort
Descending.

Table Meru Bar

Sort Ascending and Sort Descending in the Field menu
Table Button Bar

Ascending Order

Using the active field, this control puts the record with the value at the beginning of the alphabet, the earliest date, or the lowest
number, at the top of the table.

Descending Chrder

Using the active field, this control puts the record with the value at the end of the alphabet, the latest date, or the highest number,
at the top of the table,
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Examples

To Sort a Table

1. Click on the name of the field you wish to sort on to make it active. The name of the field will be highlighted.
2  Choose Sort Ascending or Sort Descending from the Table menu or the Table button bar.

Sorting always occurs an all the records in a table. If you want to sort the selected records, sort the table and then use Promote,
Promote will display the selected records at the top of the table, in the order in which they occurred in the sorted table.

When vou close a table, close the project that contains it, or export a table. Any reordering of records that you have carried out by
sorting or promoting is not saved. The next time you open the tabie, the records will be in their original order.

Joining Tables

Joining tables enables you to attach your tabular data to the themes in a view so that you can display. dentify, query, summarise,
and analyse your dota spatially.

You have a dBASE file contalning population data for all the districts in Bagmati Zone. To display this data in a view:

add the dBASE file into ArcView as a new table,

open the attribute table of a theme representing the districts,

use the Join control bo join the new table to the theme's attribute table, and
edit the theme's legend to specify which data will be displayed.

o L

Remove Joins

To remove joined fields from a destination table, use Remove All Joins from the Table menu




In this exercise, you will calculate the population density and population growth rate of each district of Bagmati Zone using the
census data from 1981 and 1991.

Add New Fields POP_91, POP_g81, DENSITY, GRW_RATE in the Theme District.

For this exercise, your first task is o add the fields representing the population in 1981 and 1991, growth rate, and population
density of each district. To do this,

click on the theme District to make it active, if it is not already active,

choose Table [rom the Theme menu or click Open Theme button in the view bulton bar,

use Start Editing from the Table menu,

choose Add Field from the Edit menu,

type POP_91 in the Name box, select Number in Type box, type 10 in Width box, and type 0 in Decimal Places box, and
similary, add felds POP_B1 (number, 10, 0), DENSITY (number, &, 2), and GRW_RATE (numdber, 4, 2),

& & & & & ®

Field Definition

] Density

Number
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Add Records

Add records for POP_91 and POP_£1 for each district as shown.

District Mame
Sindhupalchok
Kavre

Lalitpur
Kathmandu
Bhaktapur
MNuwakot
Dhading
Rasuwa

To do thas,

* use Start Editing from the Table menu,
* in the Edit menu, chocse Add Record,

POP 81

232326
H7150
184341
429737
159767
202976
243401

30241

- select Edit tool button 2% 1o update the values in cell, and

* add the values for POP_91 and POP 81.

Calculate Values

Open the attribute table for District by selecting Table from the Theme menu.

#»  |lse Start Ediﬁ.ng from the Table menu.

* Inthe table, activate the field DENSITY by clicking on it.

= Llse Calculate from the Field menuw.

The Field Calculator menu appears. Define the formula for density (pop_91/area_sq) in this menu.

* Select area_sq (area in square kilometres) from the fields.

= Select division operator (/) from the Requests box.
= Select pop_91 from the Fields' box.

POP 9
261025
324370
257086
675341
172952
245260
278068

36744




* To calculate density, activate the DENSITY field by clicking on it.
* Define the formula ([pop_91/pop_81 - 1]* 100) in the Field menu.

*  Press OK to sea both the results.

B985 17753154400

140033 | 182600

129502 | 254200 !

122729 1121.00

| 39500

164545 | 1356.00
86134 11900

126760 | 385.00

3950000

=2
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Fiald Calculator

Typa
® Number

© String

O Date

2.150000

£61025

1,420000

245250

122729

§75341

2,080000

324025 |

324323

5.880000

164545

0.560000

172852

86134/ 11900 159767

0830000 _

257086

126760 | 36500 184341

3,950000




View Statistics

Now, you may want to view the statistics of fields that you have just calculated. To view the statistics of Density,
* open the attributes table for District,

* activale the field Denaity by clicking once on it. and

= select Statistics from the Field menu.

This will give the statistics of the field Density as shown.

Sialishes tor Denzity Geld

—_

Standard Deviation: 1.71

185
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Chapter 3

Example 1

CHARTS: Visualising and Querying Data
What Is a chart ?

A chart is a graphic presentation of tabular data that provides a powerful additional visual representation of the attributes
associated with geographic features. You can use a chart to display, compare, and query your geographic and tabular data
effectively. Charts are fully integrated into ArcView's geographic user interface.

A chart references tabular data in an existing ArcView table in your project and defines how it will be displayed. A chart is
dynamic, because it reflects the current status of the data in the table. [f there is a change in the source data on which the table is

based, this change will automatically be reflected in both the table and the chart the next time you open the project file that
contains them. If you edit the table in ArcView, the chart will immediately reflect the editing.

Create a Chart to View the Population in the 1981 and 1991 Census of Each District of Bagmati Zone.

To create a chart:

1. click on the table for District to make it active and open it,

2 choose Chart from the Table menu or the Create Chart button on the button bar to open the Chart Properties dialog box,
3. in the Pick a Table window, choose the atiributes of District boundary table,

4. in the Chart Properties dialog box, select the fields {pop_81 and pop_91) that yvou want to plot on the chart and the field you
want to use to label the data series, and

3. if desired, modify the data plotted on the chart and the look of the chart.




Populibon F Y vergas 195

Chart Propames

Nama| Population 1981 versus 1991 |
Table| pat bt |
Fields Groups: 600000 + Bpastwa
Pop_91 -
Male_91 (. | Pop 81 500000 | DHADING
Female_91 B SINDHUPALCHOK
&) P
Area_s | EEETE S ENUWAKOT
— 100000 B EATHMANDI
Label series using: = B EAVEE
| District
= o il B RHAKTAPUR
Comments: - ¥
L0000 LALITPUR
0
Pop_81 Pop 91
Ik

Chart Types

ArcView provides six types of chart - area, bar, column, line, pie, and xy scatter- to appropriately display different kinds of
information. Each chart type has several variations on the basic type to select from such as adding gridlines or exploding the first
pie slics. Some charts are good for comparing values and representing trends and others are best for emphasising a significant
element. Choosing a suitable chart format for your data allows you to present your information more effectively.

Press the buttons for the type of charts you want to create.

Area Bar Column Line Pis  Scarbered
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Example:

Create a Graph to Show the Trend in Population Growth Rate by District, 1981 - 1991.

Population Growth Rate by Districl 1991 -

Population Growth Rate by Distnet, 1991

QD e b L L e Dy

Growth Rate

B pAsUwA

B DHADING

B S INDHUPALCHOK
B NUWAKOT

B EATHMANDU

B AVEE

B RHAKTAPUR

B ALITPUR




Chapter 4

LAYOUTS: Producing Maps
What is a layout ?

A layout is a map that allows you to display views, charts, tables, imported graphics, and graphic primitives. The layout is used to
prepare these graphics for output from ArcView.

A layout defines what data will be used for output and how they will be displayed. A lavout can be dynamic because it allows you
to make specific graphics live. When a graphic is live, it reflects the current status of the data. For example, if the data in a view
changes, the layout automatically reflects the change.

In this chapter, you will learn how to:

work with layouts in a project,

set up the page,
add frames,
add scale bars and north arrows, and

add graphics and text.

Working with Layouts in a Project

An ArcView project can-contain any number of layouts.

To See which Layouts Are in a Project

Click on the Layouts” icon in the Project window, The layouts in the current project are shown in the list.

To Creale o New Layout

With the Layouts” icon selected, click the New button at the top of the Project window. ArcView creates a new layout and its name

will appear in the list of layouts in the project. ArcView names new layouts in numerical order: Layoutl, Layout?, Layout3, etc. See
the Overview for creating a layout. You can also double chick the Layouts’ icon to create a new layout.
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To Open a Layout
Double click the layout’s name in the list of layouts in the Project window, or select the layout's name and click the Open button.
T Close & Layoul!

From the File menu, choose Close, or click the close option on the layout's window (This option varies according 10 the GUT you
are using).

To Remame a Layoul!

Click once on the layout in the list in the Project window and choose Rename from the Project menu. A layout's name is also a
layout property you can edit.

To Save the Work You Do wath a Layout

In ArcView, you save the work you do with any project companent by saving the project. To save your project, choose Save Project
from the File menu or click the Save Project button in the Lavout button bar.

To Copy a Layout from One Project to Another
If you want to copy a layout from another project into your cusrent project. you should mmport the other project into your current

ome using Import in the Project menu. This will copy all the components of the other project into your current progect. You can then
delete the components that you do not require using Delete from the Project menu.

Defining the Layout Page

When you want o create a map using a lavout, you will need to define some characteristics of the layout page. These include page
size, page units, orientation, and margins.

Page size

There are a nutmber of large and small format sizes provided by the default in ArcView. If you need a size other than these, you
can use A custom page size and define its width and height. The default page size is derived from your printer

|



Page units
Select page units from a list of choices. The default page units are inches.
Chrtentation

Choose between landscape and portrait orientation for the layout page. The default orientation is derived from your printer. If you
change the orientation, any new layouts will use the new orientation as the default.

Margins
Define margins for the page or use your printer's default margins. The default margins for UNIX are .25 inches. The default
margins on Windows and Macintosh are at the border of the page (0 inches), this value may change depending on your default
printer.

Chutput resolution

Define the resolution the layout is printed and exported at.
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Exercise: In this Exercise, You will create a Layout Map of Ecological Regions of the Bagmati Zone as shown below.

Ecological Regions

A
B ubs ks v sl
Bl onbess L

Celingas Lavail
Bub Top el Lo

T bl Lawm|

[ swnpn
CrgBumsa Anis
Tilghsi By

A

Note: Belore you proceed, make sure to set up the map units and the distance units of the view to metres as described in chapter 1

of this manual




Create 3 New Layout

*  Click the new button at the top of the Project window

* ArcView creates a new layout

Set-up Page

When you want to create a map using 2 layout, you will need to define some characteristics of the layout page. These include page
sire, page units, orientation, and margins.

Select Page Set-up from the Layout merm.
* Set up the page size = Letter 85 x 110 inches, page units = inches, width = 11, height = 85, orlentation = landscape, and
margins (top/bottom = 0.17; left/ right = 0.2).

T
Fage Hire: E‘_lj..!.ﬂ!,l!._-
Uratn: [ Tnabers |

widn: [T ] Hewwe (B8]

]

Margmy [ Lee prestes wordey
tou [Ri70355]  tan (iEH )
e [ 170000 | Peget [TFE |
Ceutjaiih Memerlulinn | Hormnd |

E—— & |
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Define Layout Properties
Before creating the layout, it is a good idea to define the layout that you are going to create.

* Select Properties from the Layout menu. The Layout Properties’ window appears.
* Since you are going to create a map of the Ecological Regions, type Ecologicel Regions in the Name box and press OK.

[

Gieid Spacing. Horzontat (035 | in
| veriest [§5

Eaap W0 Gnd [ |

Add View

*  Make sure that the theme Ecological Regions is displayed in the view.,
* Nuw,h:ui:l'ﬂﬂiﬁlwhﬂn]mm'mllj'nul.dkkﬂuﬂmhnthm..ﬂudupeufﬂunmrhmmhmﬂﬂsm:mrm
define the area (make a box) to be plotied in the view in your new layout. After you define the area, the view frame properties”

window appears

=

£ Live Link
O Prewera View Goale

[Pesawinios TN
mOa |pesE

*  Select Bagmati 1:250,000 (the name of your project) from the View box and press OFK. The map is displayed in your layout.




Add Legends

»  Select the legend button M8 by clicking the view & button.
* Define the legend area (making a box) in the layout. Legend Frame Properties appears.

Legend Frome Fropaies

= Select the ViewFramel: Bagmati 1:250,000 from the View Frame box and press OK. The legends are displayed in your layout
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Add Scale Bar

»  Select the the scale bar button B
*  Define the area for the scale bar in your layout. The Scale Bar Properties’ window appears.

VieswFramal: Bagmatl 1:250

Shle | me——

Units: | meters ]
Interved [(1BO0D |
intwrvals: [2 i

aft Drvisions: | 2 =

Select ViewFramel Bagmati 1:250,000 from the View Frame box.

Press OK.
Add North Arrow
*  Select the North Arrow button [

* Define the area for North Arrow in your layout. The North Arrow Manager window appears.
=  Choose a symbol for north arrow by clicking on it and then press OK.

The Units and Interval box should be automatically calculated if the map units and the distance units are set up propesly.




Add Text (Titles and sub-titles)

*  Toadd a text for the title of the map, click the text button m
Move and click the cursor where you want to place your title. The Text Properties’ window appears,

Ao onial Adigemast m
Vartical Spacng [l 10 Jlines
Rotanon Angle: [T | degrees

|L_ox—3] Foancely)
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*  Type text Ecological Regions as the title of your map. Repeal the same process 1o add other text

. anuimymrmghﬂﬁummrbuﬂm-ulddrkmhmAhﬂ:lppunummdthEMLﬂwnrﬂiuﬂubnmm
resize your text.

. Tumuvf'_r,.rmuh:tmln}ruﬂwulmmhulyﬂurhrnuL:H:kmituh‘Hu.hlmllm'lﬂuhmhrdrlggi.n;ﬂ.

Now your final map layout should look like this.

Ecological Regions

By sl Fowna

[ Dutline Boundary
Eooiagical Zones

vl Laww|
Alpine Laval
Eub-apng Lol
MWontans Leve|
B colirean Leve

Bub Topinsl Lewsl
Topoal Lewal
[ stpee

] cuktkmtad s
B et Boady

BOG L 19080 MO0 eatany @
e




Printing

Finally to print your map layout, select Print from the File menu.

Note: Before using Print, you may have to use the Print Setup to configure your printer, if it is not already configured.

Intreduction to ArcView 2.0 A Lab Exercise 199



Traiming Manual ler Pollcy-Makers






